
Audio Levels

The Status Light
The status light indicates the current state of the audio.    If the light is idle (yellow) then Connectix 
Videophone is in the state in which it can receive audio data.    When audio data does arrive the light turns
from idle to playing (red) indicating that data is being played from the remote machine.    If the light is 
recording (green), then you are recording data and if you are connected the data is being sent to the 
remote machine.    If your audio card supports bi-directional or Full Duplex (recording and playing at the 
same time), and Bi-Directional Audio=TRUE in CVPHONE.INI, then two other status light colors are used.
If audio is playing and recording at the same time, then the light will be blue.    If the audio is playing and 
able to record, then the light will be purple.

Adjusting the Volume
The volume attribute can be modified by simply moving the scroll bar to the left or right.

Adjusting the Start Level
The start level is used to tell Connectix Videophone at what audio input level you wish to start recording.   
If your sound card does not support bi-directional mode, then it can either be recording or playing, but not 
both.    Thus, if your start level is too low you may be continuously recording which would not allow your 
conference partner the opportunity to say anything.    Typically, the start level should be adjusted so that 
when you talk normally, the status light turns green (recording) and when you stop talking it turns yellow 
(idle).    If your sound card does support bi-directional audio, then the start level is used simply for quiet 
compression.    That is, when you're not talking, it isn't sending any audio data, which conserves 
bandwidth.

Adjusting the Stop Delay
The stop delay is used to smooth out the audio.    Specified in seconds, the stop delay indicates the 
amount of time that Connectix Videophone will continue to record audio data after the input levels are 
below the start level.    In other words, after you stop talking, audio data will be recorded for x number of 
seconds, where x is indicated by the stop delay.



About Connectix



Audio Compression
When Audio Compression... is selected from the Audio menu, the user is presented with the following 
dialog:

The list box in the dialog contains the names of the software audio compressors which are available.
If you are using Windows 3.1, the following choices are available:
PCM (Pulse Code Modulation) converts an analog signal to a digital one.    No compression is used.
ADPCM (Adaptive Pulse Code Modulation) uses 2:1 compression.    There are two versions: Microsoft 

and IMA (Intel).

If you are using Windows 95, the following choices are available in addition to those listed above:
CCITT A-Law uses companding (higher samples at lower frequencies) to better represent voice signals.
CCITT u-Law is similar to CCITT A-Law, above.
GSM is a good quality compressor, and results in low bandwidth requirements.
DSP TrueSpeech does not compress in real-time, and is not recommended. 

If all participants in the conference are using Windows 95, GSM is a good choice.
Highlight the compressor to use, then click OK to exit and save.    To exit without saving, click Cancel.

Important Note:    You must be able to decode the compression sent by other user, or you will not hear 
any sound.    For example, if a Windows 95 user compresses with GSM, a Windows 3.1 user will not hear 
any sound.



Requests a video conference with the highlighted person in the call list.



This is the address book of users to conference.    Each user name is associated with an address.



Address Book
The address is a simple address book to store names and addresses for people you wish to video 
conference with.    Below is the Call dialog:

Click on the dialog for more information about each individual part.

Each user is assigned an address depending on what type of communication protocol is necessary.
You must add the person you wish to conference with to the address book in order to video conferencing.



Allows you to add a person into your address book.    Clicking on the Add button opens the following 
dialog:

Each user is assigned an address for the appropriate communication protocol.
For TCP/IP use dotted decimal. (ex. 123.123.123.123)
For Novell IPX use network address, node address. (ex. 5,584efh8900)
For Modem use phone number.    (ex.    16125551212)
For Serial use COM port    (ex. com1, com2, com3, etc.)



Closes the Call dialog without initiating a conference.



Deletes the highlighted person in the Call list



Command-Line Options
You can start the Connectix VideoPhone Viewer    (CVPHONE.EXE) with several command-line options, 
and you can store command-line options in a file which can be used to start Connectix VideoPhone 
Viewer.

If you are using Windows 3.1, you can select Run from the File menu and enter CVPVIEW.EXE
with the options described below. For more examples, see the file SAMPLE.TXT, installed in the 
Connectix VideoPhone directory. 

To start the Connectix VideoPhone software using a particular network protocol, use the /p: option with 
one of four flags:

use the tcp flag to use TCP/IP 
use the ipx flag to use Novell IPX 
use the mdm flag to use a modem or ISDN 
use the ser flag to use a direct serial connection 

For example, to start Connectix VideoPhone Viewer and use a TCP/IP protocol, you might enter 
c:\cvp\cvpview.exe /p: tcp 

To automatically call a particular address when the Connectix VideoPhone software starts, use the
 /ac: <address> option.    This is used in conjunction with the /p option. The address can be an IP 
address, an IPX address, a telephone number, or a COM port

To quit Connectix VideoPhone when a you hang up a call, use the /xhu flag. 



Selecting Connection Via allows you to select which communication type to be used:
TCP/IP Network(Winsock 1.1 Compliant)
Novell Network
Direct Modem/ISDN (Modem or Hayes AT command set compatible ISDN Terminal Adapter)
Direct Serial Cable (using a Null Modem adapter)



Contacting Connectix Technical Support
If you are having trouble with your Connectix VideoPhone and can not find the solution in either the 
manual or the on-line help, you can then contact Connectix Technical Support.    The technical support 
number is 1-800 410-3137.    We also have a Web site on the internet at http://www.connectix.com.    We 
also have forums on CompuServe (GO:Connectix) and AOL (keyword-Connectix), or your can email us at
vphone@connectix.com.    We regularly post our software updates to our forums and our Web site.

For information on Connectix's other fine products send check out our Web Site or send email to 
info@connectix.com.



Sets the image to have shades of gray or black and white.    Click the Re-set button to set the contrast 
back to the QuickCams default setting.



Picture Roll
The Picture Roll contains a roll of film to which pictures can be added to, deleted from.    To snap an 
image into the roll of film, use the "Take Picture" command.    The Save, Delete, and Export commands 
allow you to manipulate the pictures in the film roll.

Save
Saves the current Picture Roll.

Delete
Deletes the highlighted picture in the Picture Roll.

Export
Allows you to export the image to several popular formats.

Close
Closes the Picture Roll.    If changes have been made but not saved, a confirmation box will be displayed 
allowing you to save or discard the changes.



If there is an address specified here, Connectix VideoPhone will automatically call this address.    This will 
also disable the address book.    If you only want a station to call one address, put the address here and 
that will be the only address available.



File Menu

Call
Opens the address book and provides a simplified means from which the user can select the 
person (host) with which to conference.

End Call
Ends the current conference.

Hold Call
This command temporarily disables a conference.    Puts the called party on "Hold".

Watch Broadcast
Allows the user to receive audio and/or video transmissions being transmitted via "Begin 
Broadcast"

Begin Broadcast
Not available in the Connectix VideoPhone Viewer.

Take Picture
The Take Picture command captures a single snapshot image, opens the film roll, and places that
image into the film roll.

Exit
The Exit command closes the Connectix Videophone Viewer.    If the configuration has changed it 
will be saved at this time.



Frame Rate
The frame rate control will allow the user to control how many frames are displayed on their Connectix 
Videophone Viewer .

Frame rate is measured in frames per-second. When the frame rate is changed a command is sent to the 
remote Connectix Videophone system to only send that number of frames per-second.    Therefore as the 
frame rate is changed the actual throughput on the network is changed. 



Frameless Window
As shown below, the frameless command causes the main Connectix Videophone application window to 
become frameless.

Since there is no longer any menu available, you can click the right mouse button to pull up a short menu 
with a few common options on it. Included in this menu is the "Frameless" option, which allows you to go 
back to non-Frameless mode.    You can also select the control menu (upper left-hand corner) to select 
non-Frameless mode.



Full-Screen Mode
You can use your entire screen to display the contents of the Main window.    To do so, choose Magnify 
from the Window menu, then choose Full Screen from the Magnify menu.    To return to normal mode, 
click the right mouse button. 



Getting Started
The Connectix VideoPhone Viewer ® is a free application that allows you to view a videoconference and 
to send audio, but does not allow you to send video.    For full audio and video capability, use Connectix 
VideoPhone ®, available at major software retailers.

To watch a videoconference broadcast, choose Watch Broadcast from the File menu.

You can also use the Connectix VideoPhone Viewer ® to request a conference, just as you can with the 
full Connectix VideoPhone ® software. To request a conference, choose Call from the File menu.    If the 
other person accepts your request, you will be able to see and hear them, and they will be able to hear 
you.



Help Menu
Index

Opens the help utility.

About this machine's addresses...

When using TCP/IP or Novell IPX, this will show This machines address.

About Connectix VideoPhone Viewer

Information about Connectix VideoPhone Viewer
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Command-Line Options

Additional Connectix Applications
Connectix VideoPhone Launcher

Getting Help
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The smaller the image size, the more lifelike the motion of your video conference will be.    Image size is 
expressed as pixels; the example shows that the image will be 160 by 120 pixels on your computer 
screen.    You can set the image size by clicking one of the preset buttons (1/4, 1/2, or Full), or by 
choosing from the drop-down menu.



Select the options that you want and click OK.
If you do not want to accept your selections, click Cancel.
If you need more help about the options, click the Help button.



Menu Commands
File
The File Menu consists of various commands to initiate conferences.

Edit
        Copy - Copies the current image into the clipboard.

Settings
The Settings Menu consists of options to change the Connection, Video, Audio, and other Preference 
options.

Window
The Window Menu contains commands which control the appearance of the Connectix Videophone 
Window.

Help
The Help Menu consists of commands that provide on-line assistance with the Connectix Videophone 
video conferencing system.



Magnify Menu

You can change the size of the Connectix VideoPhone Viewer window by choosing Magnify from the 
Window menu.

Select a magnification to change the size of the window.

0.5x is half normal size
1x is normal    size
2x is twice normal    size
Stretch to Window allows you to stretch the window to any size you like
Full Screen will take up the entire screen with the contents of the Main window.



Modem Requirements
If you wish to conference using only modems and a telephone line connection,

The computers on each end need a high-speed serial card based on the 16550 UART standard, and at least a 
v.34 (28.8 kbps) modem.
If you are using Windows 3.1, your modem must be a DSVD (Digital Simultaneous Voice and Data) modem.
If you are using Windows 95 on a Pentium 75 or faster processor, you can use any 28.8 modem for conferencing
(you do not need a DSVD modem), and you should use GSM audio compression.

For best results, we recommend the following:
Pentium 90 or faster processor
Windows 95
16 MB RAM
NSVideo Version 2.0 or 3.0 (included with Connectix VideoPhone).
GSM audio compression (included with Connectix VideoPhone).



Refresh
The refresh button will restore smooth video if the video appears to become "jerky".

From time to time, because of network delays or Windows processing delays, the video frame rate may 
appear to slow down and become "jerky".
This is an anomaly of the buffering that must be used to drive the video codec.    The refresh button will 
execute an algorithm that will cause the video codecs on both sides to reset and clean out their buffers.



Watch Broadcast
When the Watch Broadcast...option is selected from the File menu, the user is shown the following dialog 
box:

The list in the dialog box displays all broadcast transmissions which can currently be received.    The text 
is the title given to the broadcast transmission when Begin Broadcast was selected by the originating 
user.    The number represents the network port on which the transmission is being sent.



Settings Menu
Connection Via
This command lets the user change to a different communications protocol, such as TCP, IPX, etc.

Video
Not available in the Connectix VideoPhone Viewer.

Audio
Use this command to change Audio Levels or Audio Compression.

Preferences
This command will allow the users to change preferences.



Take Picture
The Take Picture command actually captures an image from the video capture device and displays the 
captured image as a bitmap in the roll of film you see below.

Saving the roll of film
The save button is enabled whenever the roll of film has changed since the last save.    To save the roll of 
film simply press the Save button.    

Deleting an image from the roll of film
To delete an image from the roll of film you must first select the image to delete.    This is done by clicking 
the left mouse button over an image and then pressing the Delete button.

Export an image from the roll of film
To export an image from the roll of film you must first select the image to export.    This is done by clicking 
the left mouse button over an image and pressing the Export button or simply double-clicking the left 
mouse button over an image.    Next, the Image Save As appears from which various image file formats 
are available.



System Requirements
Hardware Requirements

Personal Computer - 80486-50 or faster (80486-66 is recommended).
8 Megabytes RAM
3 Megabytes available hard disk space.
High density, 3.5" disk drive
SVGA or better Windows accelerator graphics card (VESA Local bus or PCI video recommended)
Windows-compatible mouse or other pointing device
A Windows Sockets compliant TCP/IP, Novel networking software, or an available COM port (modem)
16-bit Ethernet, Token Ring or other network adaptor supporting NDIS, ODI or packet drivers, ISDN 
Terminal Adapter (supporting the Hayes AT command set), or a Hayes-compatible modem (see    
Requirements for Modem Conferencing, below, if you will be using a modem to conference directly 
over a phone line).

Software Requirements
Microsoft Windows version 3.1 or later

Requirements for Modem Conferencing
If you wish to conference using only modems and a telephone line connection, we recommend the following in 
addition to the requirements listed above:

The computers on each end need a high-speed serial card based on the 16550 UART standard, and at least a 
v.34 (28.8 kbps) modem.
If you are using Windows 3.1, your modem must be a DSVD (Digital Simultaneous Voice and Data) modem.
If you are using Windows 95 on a Pentium 75 or faster processor, you can use any 28.8 modem for conferencing
(you do not need a DSVD modem), and you should use GSM audio compression.

For best results, we recommend the following:
Pentium 90 or faster processor
Windows 95
16 MB RAM
GSM audio compression (included with Connectix VideoPhone).



Serial Port Settings
To change your serial port settings, choose Preferences from the Settings menu, then choose 
Communications Port Setup. This brings up the Modem Configuration dialog, where you can change the 
following parameters:

COM Port
Which serial communications port you wish to use.    This should either have a modem attached to it, or a 
null modem cable running directly to the remote computer's serial port.

Speaker Volume

This sets the volume of the speaker.

Maximum Speed
This is the maximum speed of your modem.

For more options, click Advanced.    This brings up the Advanced panel, where you can set the following 
parameters:

Data bits
Usually set to 8.    Just make sure you and the remote computer are set the same.

Parity
Usually set to none.    Just make sure you and the remote computer are set the same.

Stop bits
Usually set to 1.    Just make sure you and the remote computer are set the same.

Use Flow Control
Check this box to use flow control, and select Hardware or Software.

Reset
Enter the reset string for your modem.    Check your modem documentation for more information.

Initialization 
Enter the reset string for your modem.    Check your modem documentation for more information.

To exit and save changes, click OK.    To exit without saving changes, click Cancel.



Settings, Audio

Enable
Toggles audio on and off

The following items are only visible if audio is enabled:

Audio Levels...
This command will allow the user to change various audio options

Audio Compression...
This command will allow the user to change audio compression options



Confirm Call
Selecting Confirm Call causes Connectix Videophone to prompt you upon receiving a conference request 
from another machine.    Should another user request a conference with you, a "Incoming Call" dialog box 
appears requesting whether or not you wish to accept the conference.



Settings, Preferences

Confirm Call
Allow the user the option of Accepting or Rejecting a conference request.

Launcher
Allows you to configure the Connectix VideoPhone Launcher

Frame Rate
Allow the user to select the Video Frame Rate.

Bandwidth
Not available in the Connectix VideoPhone Viewer.



When the "Show Status Bar" is selected, the bar is locate at the bottom of the main window.

It displays the connection status, the server status, frames per second request rate, and the 
communications type.



Storing Command-Line Options
You can store your command-line options in a simple text file whose name ends in .cvp. Files with the
.cvp extension are associated with Connectix VideoPhone Viewer, so double-clicking on one 
automatically starts Connectix VideoPhone using the command-line options stored in the file. You can 
also configure your Web browser to start Connectix VideoPhone Viewer when you download a .cvp file.

If the Connectix VideoPhone Viewer is not running when you double-click the file, it will start up and use 
the command-line parameters in the file. 

If the Connectix VideoPhone Viewer is already running when you double-click the file, it will execute the 
commands in the file. (If a conference is active, the Connectix VideoPhone Viewer will hang up before 
executing the commands.) 

Helpful Hints: 
1. The file you create must be a simple text file, which you can create and edit with the Notepad 
application in both Windows 3.x and Windows 95. The file cannot be a Microsoft Word or other word-
processor file. If you use a word processor to create the file, make sure you save it as text.

2.The Connectix VideoPhone Viewer only reads the first line of the file. 

3. The command-line options must start with a / (slash). For example, place the following commands in a 
file to start Connectix VideoPhone Viewer in TCP/IP mode and begin a broadcast when you double-click 
on the file. 

/p:tcp /bb

 



Toolbar
The toolbar provides quick and easy access to frequently used menu commands.    Click on the different 
buttons of this tool bar for further information.

The toolbar can also be toggled on and off with the toggle toolbar menu option.



Opens the address book dialog box from which a call to another machine can be initiated.



Click this button to take a picture.



Click here for information about Connectix Videophone.



Indicates a conference with another machine has been established.    If depressed, this button will
temporarily disable the conference.    To re-enable the conference, press the hold button again.



Not available in the Connectix VideoPhone Viewer..



Click this button to adjust the audio levels.



Using .cvp Files With Your Web Browser
If it supports it, you can configure your web browser to use Connectix VideoPhone as the viewer for files 
containing command-line options (.cvp   files  ).    When you click on a link to a .cvp file, your browser will 
open Connectix VideoPhone and use the commands stored in the file. Consult the documentation for your
browser to see how to configure it to use helper applications.



Video Compression
Not available in the Connectix VideoPhone Viewer.



Settings, Video
These options are not available in the Connectix VideoPhone Viewer. 



Window Menu

Show Self View
Not available in the Connectix VideoPhone Viewer.

Show Status Bar
Toggles the status bar on and off.

Show Toolbar
Toggles the toolbar on and off.

Show Pictures
This command will display the Picture Roll.

Magnify
Brings up the Magnification menu. 

Frameless
This command will turn on/off the toolbar, the status bar, the title bar, and the menu, and 
remove/add the gray space around the video image.

Always On Top
Determines whether the main window should stay on top of all other windows.

With the exception of the Magnify options, all of the items in the Window Menu are on/off options.    When 
the option is turned on, a check mark will appear beside it.    For example, if the toolbar is enabled, the 
Toolbar option will be checked.



Zoom In shows a close-up of the image by magnifying the central portion of it.    Zoom Out restores the 
image to its previous size.






